CISCO: первая настройка маршрутизатораВ этой статье описываются варианты первоночальной настройки маршрутизатора под управлением CISCO IOS. Естественно настройка любого оборудования начинается с ограничения и разграничения прав доступа.

[ad#ad-2]
Предположим, что к нам попал новый маршрутизатор. Настройки у него заводские (а в общем то никаких настроек на нем нет). Подключаемся к нему при помощи консольного шнурка, заходим через гипер-терминал и на предложение войти в "System Configuration Dialog" отвечаем "No".
Итак перед нами командная строка маршрутизатора.
Войдем в привилегированный режим

Router>enable 
Router#

И начнем настройку. Сначала назовем маршрутизатор:

Router#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hos
Router(config)#hostname Internet_router
Internet_router(config)#

Включим сервис шифрования паролей:

Internet_router(config)#service password-encryption 
Internet_router(config)#

По умолчанию маршрутизатор пытается перевести любое значение в командной строке не являющееся командой в ip адрес. Что при случайной ошибке в одной букве команды приводит к замиранию в работе на непродолжительное время.

Internet_router#pinf
Translating "pinf"...domain server (255.255.255.255)

Для того что бы этого не происходило отключим сервис domain-lookup

Internet_router(config)#no ip domain-lookup 
Internet_router(config)#^Z
Internet_router#pinf
Translating "pinf"
% Unknown command or computer name, or unable to find computer address

Далее ограничим доступ к привилегированному режиму при помощи пароля

Internet_router#conf t
Internet_router(config)#enable secret 0 test
Internet_router(config)#end
Internet_router#exit
Press RETURN to get started.
Internet_router>
Internet_router>enable
Password: 
Internet_router#

Теперь сделаем так, что бы при доступу к маршрутизатору запрашивался логин и пароль

Internet_router#configure terminal
Internet_router(config)#aaa new-model
Internet_router(config)#aaa authentication login default local
Internet_router(config)#aaa authorization exec default local 
Internet_router(config)#username test password 0 test
Internet_router(config)#end
Internet_router#exit
Press RETURN to get started.
User Access Verification
Username: test
Password: test
Internet_router>
Internet_router>enable
Password: test
Internet_router#

Вот мы и выполнили задачу самым простым способом.
CISCO IOS позволяет создавать множество локальных пользователей и для каждого из них указать уровень доступа. Так же есть возможность настроить авторизацию через RADIUS-Server, но об этом всем - в следующий раз.
P.S. если мы выполним команду Internet_router#show running-config
то увидим все то что мы настроили

Internet_router#show running-config 
Building configuration...

Current configuration : 632 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Internet_router
!
!
!
enable secret 5 $1$mERr$126VWMuSfhXn9GAlqkjPo/
!
!
!
aaa new-model
!
aaa authentication login default local 
!
!
aaa authorization exec default local
!
!
!
!
!
username test password 7 0835495D1D
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
 login
line vty 0 4
 login
!
!
!
end


Internet_router#